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1 Welcome ...

Thank you for taking the time to evaluate Bookmark Buddy. I hope that within a very short time you will
be wondering just one thing: why didn’t I know about this program sooner?

You may want to check out the key features you can look forward to using, or you may want to get
started immediately. If after consulting these help notes you have any questions or suggestions about
this program, please contact me and I will be happy to reply.

You can find a printable PDF version of these help notes at: www.bookmarkbuddy.net/BmkBuddyHelp.
pdf

Happy organizing,

Edward Leigh

2 Get Started

Bookmark Buddy is try-before-you-buy software, so you may install it and try it out for 30 days before
paying anything. Please consult the license to see the terms under which you may use the program.

1. Install Bookmark Buddy

Standard Edition

If you downloaded the standard installer (bmkbuddy.exe or bmkbuddyU.exe), open or double-click on it
to start the installation. If you downloaded the zip archive (bmkbuddy.zip or bmkbuddyU), extract the
contents into a temporary folder, then double-click the file 'setup' or 'setup.exe'.

Click on the 'Help' button at any stage of the installation to bring up more detailed information.

Portable Edition

If you downloaded the standard installer (bmkbuddyR.exe or bmkbuddyUR.exe), open or double-click on
it and select the destination folder (e.g. on your USB drive) to install the program. If you downloaded the
zip archive (bmkbuddyR.zip or bmkbuddyUR.zip), extract the contents to the folder where you want to
install the program.

2. Experiment with the basic features

When you first run Bookmark Buddy, you will see that a sample bookmark list is loaded, which you can
safely experiment with. If you imported your bookmarks into a new bookmark list, you will find it on the
File menu. Check out the different interface modes available under the Application menu (note that
windows are resizable). Switch to Organize mode and experiment with the organizing facilities: see how
to edit a bookmark, title, subcategory or category; sort or re-order titles or re-categorize bookmarks and
subcategories; and add a note to a bookmark. Then see the different ways to add a new bookmark to
the list.

3. Get to know Bookmark Buddy intimately

Bookmark Buddy’s interface is probably quite unlike any other you have encountered. Do not let this put
you off: it is very simple and fast to use. Most of the functionality of Bookmark Buddy you will discover
by experimenting, reading the startup tips, or by reading the rest of the Help notes (see in particular Hot
Keys and Keyboard Shortcuts). You may also like to download a copy of the Portable Edition to put on
a USB memory stick. Or you may be interested in the extended language support of the Unicode Edition
.

4. Buy a license

http://www.bookmarkbuddy.net/BmkBuddyHelp.pdf
http://www.bookmarkbuddy.net/BmkBuddyHelp.pdf
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Hopefully you will be so impressed by Bookmark Buddy you won’t hesitate to buy a license. However
you have 30 days to decide and e-mail support is always available to answer your queries.

3 Key Features

Bookmark Buddy is a highly sophisticated tool for storing and organizing your bookmarks. These are its
key features:

Finding bookmarks

Three clicks: category, subcategory, bookmark.
Fast full-text search facility with options to restrict which fields are searched; whether matches are
case-sensitive; whether whole or partial word matches are sought.
Show search results as a list or by highlighting.
Filter searches by rating, date and site status.
Refine searches (search within previous search results).
Store searches.
View bookmarks as a list, ordered alphabetically or by date, rating, or number of visits.
Schedule one-off or regular visits to bookmarked sites or documents.
SmartFolders: automatically-maintained aliases to recently visited, recently added, frequently visited,
scheduled to visit, and user-selected favorites.

Organizing bookmarks

Add, edit, sort and delete items using intuitive 3-panel interface.
File bookmarks in multiple folders using aliasing.
Move items around using drag-and-drop and mark-and-move.
Check status of (validate) web site bookmarks in the background.
Find duplicates and delete or convert into aliases.
Add separators (optionally with text) to visually subdivide items.
Make items bold.

Bookmark collections

Each collection can contain up to 60,000 items (bookmarks, folders, aliases and separators).
Protect site passwords stored in a bookmark collection using 128-bit Blowfish encryption and a single
password.
Protect entire bookmark collections using 128-bit Blowfish encryption.
Instantly switch between bookmark collections.
Move or copy bookmarks between collections.
Export bookmarks to a printable document, web page, spreadsheet, or any other text format using the
template-based export facility.
Automatically maintain a 3-stage backup of each collection.
Manually backup using 'Save copy'.
Readily share bookmark lists with other users.

Web browser functionality

Import and export Internet Explorer favorites
Import and export Netscape, Mozilla, Firefox and Yahoo Toolbar bookmarks
Import and export Opera hotlists
Import and export MSN favorites
Import Safari bookmarks
Import AOL and CompuServe 2000 Favorite Places
COM and DDE support for communicating with almost all web browsers.
Drag and drop bookmarks to and from any web browser.
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Fetch bookmark from frontmost browser tab or from a list of open browser tabs.
Open bookmark in a new tab or frontmost browser tab (where supported by browser).
QuickLogin: Fill out most log-in pages and windows with a single keystroke.
QuickSearch: enter search terms before loading a web page.
Switch between different web browsers instantly.
Specify which browser to use for a particular bookmark.

Windows functionality

Import and export Start Menu shortcuts.
Open programs, folders and documents.
Open the containing folder of a program or document. 
Open folder in 'My Computer' or Windows Explorer-style window. 
Use wildcards in document path names: ? (single character) and * (any number of characters). 
Drag and drop bookmarks to and from any document.
Copy bookmarks in a variety of text and HTML formats.
QuickLogin: Fill out most log-in windows with a single keystroke.

Types of bookmarks that may be stored

Internet bookmarks/favorites/favourites/address/URLs
E-mail addresses
Newsgroup addresses
Application/program, document and folder shortcuts

Metadata stored with each bookmark

Notes
Site log-in names and passwords
Keywords (to aid searching)
Ratings (to aid selection)
Times of last and previous-to-last visits, entry creation and modification, site check and update
Schedule of future site visits
Count of number of visits

High usability interface

Alternative interfaces: ‘Regular’, ‘Organize’ and ‘Compact’
Optional use of Tool Tray
Comprehensive keyboard shortcuts and hot keys
User-selectable font face and size for main window
User-definable color scheme
Optional flat style controls with improved usability

Miscellaneous

Loads in a snap and uses minimal disk space, memory and resources
Includes comprehensive integrated help notes
Import and export URL Organizer URL lists
Unicode Edition supports mixed, non-Latin character sets
Portable Edition runs off removable media on any (Windows) computer

4 Program Editions

Bookmark Buddy is available in four editions (which you can download from www.bookmarkbuddy.net/
download.php):

http://www.bookmarkbuddy.net/download.php
http://www.bookmarkbuddy.net/download.php
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Standard Edition

This edition is compatible with all versions of Windows from Windows 8 back to Windows 95, and is
therefore recommended for most users.

Unicode Edition

This edition allows you to hold bookmark titles and notes in almost all characters sets, including
Chinese, Japanese, Arabic and Russian. It is compatible with Windows 8 back to Windows 2000. It
stores bookmark lists in Unicode text format (which is editable only by Unicode-aware text editors).

Portable Edition

This edition has nearly all the functionality of the Standard Edition, but does not require installation or
registration: the program files can be copied to any device or folder and run from there. You can therefore
run Bookmark Buddy from a USB memory stick, MP3 player or floppy disk. Settings are stored in a file
(BmkBuddy.xml) in the same folder as the program file (rather than in the Windows Registry). To fully
enable this edition you must copy your Personal License Register to the top level folder of the portable
drive.

Unicode Portable Edition

This edition combines the features of the Portable and Unicode Editions, allowing use of Unicode
bookmark lists from a portable drive.

Switching between Standard and Unicode Editions

If you open a non-Unicode (ANSI) bookmark list, Bookmark Buddy will create a copy and convert it to
Unicode, leaving the original intact. (The same principle applies if you open a Unicode bookmark list in
the Standard Edition.)

If you uninstall one edition when you have both editions installed, you should select Modify/Repair setup
from the Application menu of the edition you keep. This ensures that the program is correctly registered
with Windows. If running Windows Vista or later in User Account Control Mode (the default) you will
need to re-run the installer for the edition you keep.

5 License & Registration

5.1 License

Bookmark Buddy is copyright (1998-2015) of Edward Leigh. It is NOT public domain or ‘freeware’.

In the license conditions that follow, these terms have special meaning:

‘Program’ shall refer to Bookmark Buddy.
‘Author’ shall refer to Edward Leigh, the author of Bookmark Buddy.
‘Individual Licensee’ shall refer to an individual user of the Program plus any family with whom he/she
regularly shares a computer.
‘Corporate Licensee’ shall refer to the company that employs one or more users of the Program.
‘Licensee’ shall refer to either a Corporate Licensee or Individual Licensee, as appropriate for the user.
‘Full User License’ shall refer to the supplementary license required to access the full functionality of
the Program.

The Author grants the Licensee the right to use the Program on any computer providing that the
Licensee agrees to be bound by the following conditions:

The Program is provided ‘as is’. The Licensee uses the Program entirely at his/her/its own risk.
No warranties nor guarantees are included with this license. In no event shall the Author be liable for
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any consequential damages whatsoever (including, but not limited to, damages for loss of business
profits or loss of business information) arising out of the use of, or the inability to use, the Program. In
any case, the Author’s liability shall be limited to the price paid for any Full User Licenses.
No other rights with respect to the Program are granted to the Licensee.
If the Licensee desires access to the full functionality of the Program, after any trial period is over, he/
she/it must obtain a Full User License.
One Full User License is valid for one Individual Licensee or one employee of a Corporate Licensee.
Full User Licenses may be transferred between employees of a Corporate Licensee, but not from and
back to the same employee within a 30 day period.
For the avoidance of doubt, the number of Full User Licenses required does not equal the number of
computers on which the program is installed, nor the number of concurrent users of the Program.
The Licensee shall not reverse engineer, de-compile, disassemble or modify in any way whatsoever
the Program, except as permitted by applicable law.
The Licensee shall not give or lend its license key (encapsulated in a ‘Personal License Register’) to
anyone else.
The Licensee shall not sell, rent or lease the Program to anyone else.
The Licensee may distribute only the most recent installation package as available from the Author’s
web site.
The Licensee shall respect all national and international intellectual property laws and treaties that
apply to the Program, including copyright, trademarks and patent rights.
This licence agreement is governed by the laws of England and Wales.

If The Licensee does not agree with the stated license conditions, the Licensee must uninstall the
Program (if already installed) and erase all copies of the installer.

See also:

Buy a License

5.2 Buy a License

Bookmark Buddy is SIVL-compliant try-before-you-buy software. In order to fully-enable the program’s
functionality you must purchase a license. A license to use Bookmark Buddy (see the terms of the
license) normally costs US$19.95. Up-to-date pricing, including upgrades, special offers and discounts,
is available on the OSoLiS registration site: www.osolis.com/register.cgi?P15

OSoLiS currently accepts payment on-line by VISA, Mastercard, American Express, Discover, PayPal
(which includes e-check, Switch, Solo and Visa Electron), or by fax/mail by card, ACH (‘bill pay’), US
dollar check or postal money order. Please contact me if you are unable to pay in any of these ways.

Functionality is limited after the 30 day evaluation period is over, but you will always have access to your
bookmarks and, should you decide that Bookmark Buddy is not for you, you can export your bookmarks
back to Internet Explorer, Netscape, Mozilla, Firefox, MSN, Opera or URL Organizer.

Registration steps

To access the OSoLiS registration service, either:

Go to Buy online now under the Help menu, and click the Register button whilst you are connected to
the Internet,
or
Go on the Internet to www.osolis.com/register.cgi?P15 and follow the instructions there.

You will find instructions on OSoLiS’s site, but the basic steps are:

1. Register your contact details. (Your details will be kept private.)
2. Buy a license for Bookmark Buddy (Program ID: P15).
3. Save or download your Personal License Register to your Desktop.

http://www.osolis.com/register.cgi?P15
http://www.osolis.com/register.cgi?P15
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4. Exit Bookmark Buddy, URL Organizer and any other programs you have purchased from OSoLiS.
5. Check that the Personal License Register file is named licences.rv1 (l-i-c-e-n-c-e-s-dot-r-

v-one).

6. Move the License Register to the top level of the drive on which Bookmark Buddy is installed (usually
C:\), replacing your existing License Register if you have one. If you are not sure where to put the
License Register, run Bookmark Buddy and check the message on the About Bookmark  Buddy
window (accessed via the Help menu).

(You may previously have placed your Personal License Register in the C:\WINDOWS folder. This is no
longer necessary.)

Cannot replace existing License Register

If you find you get an error when trying to move your Personal License Register, you probably still need
to exit from other SIVL-compliant programs that you are running (including URL Organizer).

See also:

Online registration system
OSoLiS online instructions
License terms and conditions
Registration Problems

5.3 Registration Problems

If you have difficulties obtaining your Personal License Register from OSoLiS, please see www.osolis.
com/en/registration/plr.shtml or contact Support at client.support@osolis.com

If Bookmark Buddy doesn’t recognize that it is registered, please check About Bookmark  Buddy under
the Application menu to see what is wrong. Below are some suggestions for what to do depending on
the message you see. If you still need help please e-mail me with the message Bookmark Buddy
reports.

If you install Bookmark Buddy on a new computer, or you install on a reformatted hard drive, then you
will need to obtain and install a new copy of your Personal License Register (see below).

License Register missing

You must place the Personal License Register in the directory that Bookmark Buddy says it is looking
in. If the file you have is called osolis.zip, then you must ‘unzip’ it to extract the actual Personal License
Register. If you do not know how to unzip a file, or you have lost your Personal License Register, see
below for how to obtain a new copy of your Personal License Register.

License Register corrupt

If the Personal License Register has become corrupted, then you will need to obtain another copy: see
below.

License Register indicates that you do not have a license

You will see this message if you have an out of date Personal License Register installed. You must
replace the Personal License Register file with the latest version that includes details of your Bookmark
Buddy license. Be sure to exit URL Organizer and Bookmark Buddy before saving your Personal
License Register.

To obtain a new copy of your Personal License Register

1. Log back into your account with OSoLiS using the Register button in About Bookmark  Buddy, or
starting from www.osolis.com/login.cgi?plr

2. Click on the License Register button.
3. Choose to have your Personal License Register e-mailed to you unless you have experienced

http://www.osolis.com/register.cgi?P15
http://www.osolis.com/en/registration/plr.shtml
http://www.osolis.com/en/registration/plr.shtml
http://www.osolis.com/en/registration/plr.shtml
mailto:client.support@osolis.com
http://www.osolis.com/login.cgi?plr
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difficulty receiving e-mails from OSoLiS.
4. Save/move/copy your Personal License Register to the top level of the drive on which Bookmark

Buddy is installed (usually C:\), overwriting your existing Personal License Register if applicable.

See also:

Online registration system
OSoLiS online instructions

5.4 Upgrades

New releases of Bookmark Buddy fall into two categories: ‘updates’ and ‘new editions’. All updates to
Bookmark Buddy carry a version number of 3.x. These are all free to registered users of Bookmark
Buddy.

You can (and should) install an update over an existing installation without affecting your preferences,
bookmark list files or registration status. You will be asked whether you want to update the export
templates in case you have customized them yourself (though it’s best to give a customized template a
new name to ensure it is never overwritten by the installer).

See also:

Re-install
Plans for Future Releases
Registration Problems

5.5 Affiliate Program

Registered users are invited to join an Affiliate Program offering significant earning potential. If you sign
up, you will be entitled to receive a proportion of each sale of Bookmark Buddy that you generate. You
will be offered a discount on the normal sale price (typically around 25%), some of which you may pass
on to the purchaser as an incentive to buy ‘from’ you rather than direct; the rest of the discount is
credited to you after each sale is confirmed. To find out more about how the Affiliate Program works and
to sign up, visit: www.bookmarkbuddy.net/affiliates.shtml.

6 Installing & Uninstalling

6.1 Install

To install Bookmark Buddy for the first time, run setup (or setup.exe). You will be presented with various
setup options, described here. You can change any of these options even after Bookmark Buddy has
been installed.

Location of application files

Choose the folder in which you want Bookmark Buddy and the help files to be stored.

Shortcuts

Start Menu program group: Include a shortcut to the program, help file and uninstall on the Start Menu
under Programs. You can choose a subfolder in which to create the program group.
Desktop: Include a shortcut on the desktop
Quick  Launch bar: If it is installed, the Quick Launch bar sits in the Task Bar, usually by the Start
button.
Startup items: If you want Bookmark Buddy to launch when you start up your computer, include a
shortcut here.
Start Menu: Include a shortcut to the program at the top level of your Start Menu.

http://www.osolis.com/login.cgi?plr
http://www.osolis.com/en/registration/plr.shtml
http://www.bookmarkbuddy.net/affiliates.shtml
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Default location for list files

This folder is the one you will be offered first when you save a new bookmark list. It is also where the
sample bookmark list file will be moved. You can either use the application folder or you can choose
another.

Installing for a ‘Limited User’ account

You must first be logged in as an ‘Administrator’ to install Bookmark Buddy. Then log in as a user and
select Bookmark Buddy from the Start menu (under All Programs). The program will first run  in ‘setup’
mode to configure user-specific preferences.

Multiple installations

If you are rolling out installations on several computers, you can prime each installation with the same
preferences by adding a preferences back-up file, BmkBuddy.sav, to the installation archive as follows:

1. Install Bookmark Buddy on one computer from the zip archive (not the self-extracting version).
2. Configure the preferences (list files, browsers, behavior and presentation) as you want.
3. Exit Bookmark Buddy.
4. Locate the preferences backup file, BmkBuddy.sav, which will usually be in C:\Documents and

Settings\<your name>\Local Settings\Application Data\Edward Leigh\Bookmark  Buddy\3.0 (or ...
\3.0U for the Unicode Edition).

5. Open the installation zip archive.
6. Add the file BmkBuddy.sav to the installation zip archive.
7. Install Bookmark Buddy on the other computers from the modified zip archive.

See also:

Buy a License
Registration Problems
Preferences & Configuration
Change Setup after Installation
Re-install

6.2 Change Setup after Installing

To modify any of the setup options from within Bookmark Buddy select Modify Setup from the
Application menu.

Location of application files

If you specify a new location for Bookmark Buddy, Bookmark Buddy will exit when you press Setup Now
. You must then re-launch Bookmark Buddy in its new location. Any shortcuts will be modified to point
to Bookmark Buddy in its new location.

Shortcuts

If you deselect a shortcut option, the corresponding shortcut will be deleted; if you select a new shortcut
option, the corresponding shortcut will be created.

Default location for list files

If you change this, then any bookmark lists in the current default folder will be moved to the new
location.

See also:

Install
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6.3 Install Update or Re-install

You can install Bookmark Buddy any number of times without affecting your registration, bookmark lists
or preferences.

As long as you do not move or erase your Personal License Register then Bookmark Buddy will
recognize that it is registered. If Bookmark Buddy doesn’t recognize that it is registered, or you know
that you have lost your Personal License Register see Registration Problems.

Restore program preferences

If you have a backup of your 'Documents and Settings' folder (usually C:\Documents and Settings\), you
can find a backup of your Bookmark Buddy Preferences, BmkBuddy.sav, inside C:\Documents and
Settings\<your name>\Local Settings\Application Data\Edward Leigh\Bookmark  Buddy\3.0 (or ...\3.0U
for the Unicode Edition). If you find that file then you can restore your preferences as follows:

If you have already run Bookmark Buddy once, then you must first:

1. Re-launch Bookmark Buddy*
2. Select Uninstall from the Application menu
3. Uncheck all options except ‘Remove entries from Windows Registry’
4. Click on Uninstall Now.

*If running Windows Vista or later you must instead exit Bookmark Buddy and select Uninstall from the
Bookmark Buddy program group on the Start menu, or go to uninstall Bookmark Buddy via the Add/
Remove Programs Control Panel.

Then:

1. Locate the file BmkBuddy.sav from your backup (see above).
2. Copy BmkBuddy.sav into the folder where Bookmark Buddy is currently installed (usually C:

\Program Files\Bookmark  Buddy\).
3. Launch Bookmark Buddy.

Your original preferences should be restored.

See also:

Registration Problems
Preferences & Configuration
Change Setup after Installation

6.4 Uninstall

Standard (ANSI or Unicode) Edition

To uninstall Bookmark Buddy, either:

Choose Uninstall from the program’s Application menu.
Select Uninstall from the Bookmark Buddy program group on the Start menu.
Go to the Add or Remove Programs Control Panel, select Bookmark Buddy, and click on Change/
Remove.

You will then be asked which components you wish to remove before they are finally erased. (If you only
want to reset the Windows Registry entries, uncheck the other items.)

If running Windows Vista or later, the first option is not available to you. And, if running in User Account
Control mode (the default), you must exit Bookmark Buddy before trying to uninstall it by one of the
other methods.
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Reader (ANSI or Unicode) Edition

Simply delete the program files. 

7 Bookmark Lists

7.1 About Bookmark Lists

Bookmark Buddy stores your bookmarks in a simply-formatted text file, essentially a tab-delimited text
database. Internet Explorer’s method of storing shortcuts is inherently slow and offers no facility for
storing notes; Netscape’s bookmark file can be difficult to edit manually, and cannot be extended; so I
came up with a simple, readable format to use instead.

Bookmark Buddy supports any number of different list files concurrently. This effectively gives you
another level in the hierarchy above Category. You might have one list for business-related bookmarks,
one for leisure bookmarks, and one for applications installed on your computer, and others created for
one-off projects. If you are using Bookmark Buddy at home, you can let family members build up their
own lists independently.

Each list can hold up to 60,000 items (categories, subcategories, bookmarks, aliases and separators).
However if you are getting into the high thousands, you may want to break your bookmark collection into
smaller parts, and save each in a separate bookmark list (see Move or Duplicate Items).

You can switch between lists on-the-fly from the File menu or, for the first ten lists, using the
Ctrl+<digit> shortcut indicated in the File menu. You can toggle back and forth between two lists with
Ctrl+Tab.

If you use more than one computer, you can access a list file over a network, or you can store one copy
in a ‘Briefcase’ to keep it synchronized with the master copy.

See also:

Open, Add or Remove a Bookmark List
Import a Bookmark Collection
Save a Bookmark List
Export a Bookmark List
Backup a Bookmark List
Edit a Bookmark List Manually
Move or Duplicate Items

7.2 Open, Add or Remove a Bookmark List

To include an existing bookmark list in the File menu

1. Select Open/New from the File menu.
2. Select the list in the file browser and click Open.
3. To change the name that Bookmark Buddy uses to refer to a list, or to re-order the lists in the File

menu, select Configure from the File menu.

To create a new, blank bookmark list

1. Select Open/New from the File menu.
2. Select the folder in which you want to save the new bookmark list.
3. Type the name you want to give the new bookmark list and click on Open.

To create a new bookmark list from your Internet Explorer favorites, Netscape bookmarks, MSN
favorites, Opera Hotlist, AOL or CompuServe Favorite Places, URL Organizer URL list, or Start Menu
shortcuts, see Import a bookmark Collection.
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To remove a bookmark list from the File menu

1. Select Configure from the File menu.
2. Click on the Remove button. (This does not erase the list file.)

To re-order the File menu

1. Select Configure from the File menu.
2. Drag names up or down the list box to change the order in which they appear on the File menu.

Keyboard shortcuts are assigned to the first ten bookmark lists in the order in which they are
displayed.

See also:

Import a Bookmark Collection

7.3 Save a Bookmark List

Bookmark Buddy automatically saves the open bookmark list every ten minutes or whenever you:

switch between Regular, Organize or Compact modes
switch to another bookmark list
open Bookmark Buddy Preferences window
exit Bookmark Buddy

To force changes to be saved at any other time, select Save from the File menu or type Ctrl+S.

You can save a copy of an open bookmark list by selecting Save Copy from the File menu and choosing
a location and name for the copy.

The status line at the bottom of the Regular/Organize mode window indicates how long ago the list file
was last saved. An asterisk indicates that the list has changed since it was last saved.

See also:

Backup a Bookmark List

7.4 Import a Bookmark Collection

Bookmark Buddy can import favorites from Internet Explorer and MSN Explorer, bookmarks from Firefox,
Netscape, SeaMonkey, Camino, Mozilla, Safari, Compass, Powermarks and Yahoo! Toolbar, hotlists
from Opera, Favorite Places from AOL and CompuServe 2000, shortcuts from your Start Menu and URL
lists from URL Organizer 1 & 2. Here’s how:

1. From the File menu select Import.
2. Select the format of the bookmark collection you want to import.
3. Select the user/profile you want to import. Bookmark Buddy remembers the path name of the last

imported or exported bookmark file in the selected format.
4. If necessary, change the path name of the source file/folder. AOL and Compuserve users, see below.
5. Choose whether to append to an existing bookmark list, or import into a new bookmark list (in which

case you may want to change the path name).
6. Set the options you require (see below).
7. Press the Import button.
8. If there’s a problem, check that the Source file or folder is correct, and if necessary choose another.

Options

Add http:// to addresses missing protocol prefix: Where a bookmark address is missing a prefix (e.g.
www.urlorg.com/index.html), Bookmark Buddy will prepend http://.
Sort alphabetically: Bookmark Buddy will sort all bookmarks into alphabetical order.

Set initial bookmark  rating: Bookmarks may be imported with no rating selected or with a rating of 3 (out
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of 5) stars.

Observations

Bookmark Buddy will not detect duplicate bookmarks at this stage, but you can deal with these after
import – select Manage duplicates from the Edit menu.

In order to fit your bookmarks into a 3-tier hierarchy, Bookmark Buddy has to do some pre-arranging of
its own. These changes are only reflected in the imported bookmark list, not in your original favorites/
bookmarks/hotlist/shortcuts.

Where you have bookmarks that are at the top level of the bookmark collection, Bookmark Buddy
inserts both a category and subcategory heading (‘Uncategorized’) above those bookmarks. Where you
have bookmarks one folder down from the top level, Bookmark Buddy inserts a subcategory heading
(‘Uncategorized’) above those bookmarks. You can change the ‘Uncategorized’ headings to something
else afterwards.

Where you have bookmarks more than two folders down from the top level, the bottom level folder is
effectively moved up one or more levels to become a subcategory. Because this may not be what you
want, it may be advisable before you import to rearrange the folders so that you do not have any folders
within folders within folders.

Ideally you would start with a bookmark collection that has:

a top level of just category folders
a second level of just subcategory folders
a third level of just bookmarks

Import Yahoo Toolbar Bookmarks

You must first export a copy of your bookmarks to your computer:

1. Log into Yahoo.
2. Click on the Y! Bookmarks button and select Edit/Import Bookmarks.
3. Click on the link Export Bookmarks.
4. Follow Yahoo’s instructions for exporting your bookmarks.
5. Follow the steps above for importing the exported bookmark file into Bookmark Buddy, selecting 

Netscape/Mozilla/Firefox/Yahoo Bookmarks as the format.

Import AOL & CompuServe Favorite Places

As of Compuserve 2000, the software can export to the same ‘Personal Filing Cabinet’ file format that
AOL can. To import your Favorite Places from AOL or Compuserve, you must first save them to a
separate ‘Favorite Places’ file.

To do this in Compuserve 2000 or AOL version 5 or later:

1. Launch AOL/Compuserve.
2. Select ‘Favorite Places’ from the ‘Favorites’ menu.
3. Click on the ‘Save/Replace’ button at the bottom-right of the Favorite Places window.
4. Leave ‘Save the Favorite Places …’ option selected
5. Click on ‘OK’.
6. Choose a suitable place to save the Favorite Places file. If necessary, make a note of where you save

the file so that you can find it again with Bookmark Buddy.
7. Click ‘Save’.
8. In Bookmark Buddy, follow the steps above for importing a bookmark collection, choosing ‘AOL/

Compuserve Personal Filing Cabinet’ as the format and selecting the Favorite Places file you have
just saved.

To do this in AOL version 4:

1. Launch AOL.
2. Select ‘Favorite Places’ from the ‘Favorites’ menu.
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3. Right-click on the ‘Favorite Places’ folder at the top of the Favorite Places window.
4. Select ‘Save Folder As’ from the pop-up menu.
5. Choose a suitable place to save the Favorite Places file. If necessary, make a note of where you save

the file so that you can find it again with Bookmark Buddy.
6. Click ‘Save’. (You can close the new window that opens listing your Favorite Places again.)
7. In Bookmark Buddy, follow the steps above for importing a bookmark collection, selecting ‘AOL

Favorite Places’ and the Favorite Places file you have just saved.

AOL favorites are sometimes stored without the http:// protocol prefix, so it is usually a good idea to
check the option Add http:// to addresses missing protocol prefix.

See also:

Open, Add or Remove a Bookmark List
Frequently-Asked Questions

7.5 Export a Bookmark List

Bookmark Buddy can export a bookmark list as Internet Explorer favorites, a Netscape/Mozilla
bookmark file, an Opera Hotlist or a URL Organizer URL list:

1. From the File menu select Export.
2. Choose the source bookmark list and select any suitable options.
3. Select the export format.
4. Check or choose the path name of the file or folder to which the bookmark list will be exported.
5. Press the Export button.

To export to Netscape, Mozilla, Mozilla Firefox or Yahoo Toolbar, use the Netscape bookmarks
template.

Note that whilst exporting to MSN Explorer works in most cases, there appears to be a limit on the
number of bookmarks MSN Explorer can hold. When the limit is exceeded, the entire bookmark list is
erased by MSN Explorer. Since the limit appears to be above 1,000 bookmarks it should affect very few
people.

Templates

Bookmark Buddy uses templates for exporting (except for Internet Explorer favorites and Start Menu
shortcuts, which are stored as special Windows files). All templates are stored in a folder called 
Templates within the Bookmark Buddy program folder (usually C:\Program Files\Bookmark Buddy).

The templates are text files that may be edited and created using any text editor, such as Notepad. The
format is simple yet powerful and is fully documented in the template called Blank (documented). When
you are familiar with the formatting, you may want to adjust the existing templates and create new ones.
As long as they are correctly formatted and saved in the Templates folder, Bookmark Buddy will
automatically update the list of available export formats in the Export Bookmark  List dialog window.

If you modify an existing template, it is a good idea to give it a new file name so that you can’t
accidentally overwrite it when you install an update to Bookmark Buddy (the installer does ask first, but
just in case you accidentally press the wrong button!) In any case be sure to keep a backup of your
custom templates.

Merging bookmark collections

Internet Explorer & Start Menu: Each exported shortcut is saved with the following path name relative
to the folder you select for export: <Category title>\<Subcategory title>\<bookmark title>. Beware of
overwriting existing favorites/shortcuts if you export your bookmark list into an existing Internet Explorer 
Favorites folder. You may want to erase all your favorites/shortcuts before you export.

Opera: To merge your bookmarks with an existing Hotlist, export your bookmarks to a new Hotlist file.
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Then in Opera, right-click on the Hotlist window and select Insert File from the File menu, and select the
exported Hotlist file. Note that Opera will not detect duplicate bookmarks if there are any.

Other formats: To merge your bookmarks with bookmark lists in other formats, you should import all
the bookmarks into a single bookmark list in Bookmark Buddy, then export the combined list in
whatever format you want.

See also:

Save a Bookmark List
Import a Bookmark Collection

7.6 Backup a Bookmark List

Bookmark Buddy automatically maintains three backup copies of your bookmark lists. They are saved in
the same folder as the original bookmark list and are named:

Autobackup of [bookmark  list file name]
This is renewed if it is over 1 hour old when the bookmark list is saved.
Autobackup (older) of [bookmark  list file name]
This is renewed if it is over 1 day old when the first autobackup is renewed. It is always at least 1 hour
old.
Autobackup (oldest) of [bookmark  list file name]
This is renewed when the ‘older’ autobackup is renewed. It is always at least 1 day old.

To check the file path (location and name) of a bookmark list, see the Bookmark Lists Preferences.

Restore a backup

If Bookmark Buddy reports that your bookmark list is corrupted or you realize that you have accidentally
made changes you didn’t mean to make:

1. Do not exit Bookmark Buddy. (This ensures that your autobackup copies are not renewed.)
2. From the File menu, select Revert.
3. Select the backup stage you wish to restore.

See also:

Save a Bookmark List

7.7 Encrypt/Protect a Bookmark List

To encrypt your site passwords and/or an entire bookmark collection:

1. From the File menu, select Encryption Options.
- or -

Click on the key icon  beside the log-in field of the Notes window.
2. Choose whether you want to encrypt the site passwords and/or the entire bookmark list.
3. Enter the password you would like to use as the encryption key (twice to avoid typos).

If you have previously set an encryption password, you will need to enter the existing password before
any changes to the encryption options can be made.

Encrypted log-in passwords

If you choose to encrypt site log-in passwords, you will see a padlock icon  button beside the site
password field in the Notes window. Click on this and you will be prompted to enter the encryption
password before you (or anyone else) can see any site passwords. Click on the unlocked padlock icon 

 to re-lock all site passwords.
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Click on the password edit box to reveal an individual password when site passwords are unlocked.

Encrypted bookmark list

If you choose to encrypt the entire bookmark list, you will be prompted to enter the encryption password
when you next open the bookmark list. If you do not also choose to encrypt site log-in passwords then
these will all be unlocked and viewable once the bookmark list is decrypted.

Remember decryption password

Normally each time you switch back to an encrypted bookmark list or unlock your site passwords you
must enter your password. You can choose to have Bookmark Buddy remember your passwords so that
you only need enter them once during a session with Bookmark Buddy:

1. From the Application menu select Preferences.

2. Check Remember encryption passwords til exit.

DO NOT FORGET YOUR PASSWORD! THERE IS NO WAY TO RECOVER A FORGOTTEN
PASSWORD NOR ANYTHING YOU HAVE ENCRYPTED WITH IT.

Bookmark Buddy employs industry-standard, full-strength 128-bit Blowfish encryption.

See also:

Notes Window
Fill Out a Log-in Form
Behavior Preferences

7.8 SmartFolders

Bookmark Buddy automatically maintains aliases to bookmarks that you are likely to want again soon:

Favorites: These are aliases that you choose yourself. Right-click on any bookmark and select Add to
Favorites.

Due to visit: These are bookmarks that you have scheduled to visit today.

Frequently visited: These are the most frequently visited bookmarks ranked by the total number of visits
recorded (which is shown in the extended Notes window).

Recently added: These are the most recently added bookmarks in time order (most recent at the top).

Recently visited: These are the most recently visited bookmarks in time order (most recent at the top).

You can set the maximum number of bookmarks that Bookmark Buddy will put in a SmartFolder in 
Presentation Preferences.

If you do not use the SmartFolders, drag the SmartFolders category out of the way to the bottom of the
category list.

See also:

Notes window
Behavior Preferences
Presentation Preferences

7.9 Edit a Bookmark List Manually

You can edit a bookmark list using a spreadsheet editor (such as Excel) as long as you bear in mind
the following:

Do not try to edit a list whilst it is open in Bookmark Buddy (you won’t be able to re-save it).
Do not modify the first line: this contains information needed to maintain the file, as follows:
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BMKBUDDY/[file version indicator]/[encryption level indicator]/[last itemID used]/[list identifier]/
[encryption hash]
It is best to copy all but the first line of the bookmark list into a blank spreadsheet, then copy and
paste back to the bookmark list, leaving the first line intact.
The column headings, contained in the second line of the bookmark list file, should be self-
explanatory.
If you add bookmarks, allocate item IDs starting after the number shown in the file header.
The order items are listed is the order they are displayed in Bookmark Buddy.
If the passwords are encrypted, edit or enter these only in Bookmark Buddy.
If the list file is encrypted, do not edit anything!

You are advised as a precaution to save a copy of your bookmark list before you start editing it!

See also:

Save a Bookmark List

7.10 Print a Bookmark List

Export your bookmarks to one of the printable formats available (html is recommended). When the
export is finished, choose to open the exported document. Print the document from whichever
application opens it.

See also:

Export a Bookmark List

7.11 Export a Bookmark List to the Web

Export your bookmarks to one of the web formats available. The dynamic html web format is the most
usable, and should be compatible with older web browsers even if the collapse/expand feature does not
work.

See also:

Export a Bookmark List

7.12 Share a Bookmark List

Bookmark Buddy will let you access the same bookmark list from more than one computer over a
network. The first user to open the bookmark list has read-write access, so is able to update the list;
anyone else who then opens that bookmark list will have read-only access, so any changes they make
(to notes or Last Visited times) will not be saved (unless they save a copy of the bookmark list). In short,
any number of users can read a bookmark list; only one user can update it.

In a Windows 95/98/ME networked environment I recommend the following:

1. Create a ‘master’ bookmark list and have one user maintain it ‘privately’.
2. Copy the master bookmark list to a public/shared location and set its properties to read-only (in

Windows Explorer, right-click on the bookmark list file and select Properties and check Read-only).
3. Let users know where they can find the shared copy of the master bookmark list.
4. Whenever the original of the master bookmark list is updated, copy it over the shared version.

If you can set user access privileges for individual files:

1. Create a ‘master’ bookmark list in a public/shared location and set its ‘sharing’ properties to permit
read-write access for a named user (or for all Administrators) and read-only access for everyone else.

2. Let users know where they can find the shared copy of the master bookmark list.
3. Whoever has read-write access to the master bookmark list will be able to update it. If more than one

person has read-write privileges, only the first person to open the bookmark list will be able to update
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it.

In both cases, changes will be apparent to users when they next reload the master bookmark list (e.g.
by re-selecting the list from the File menu). Users can of course create their own separate bookmark
lists.

8 Finding & Opening Bookmarks

8.1 Find a Bookmark

To select a bookmark

1. Select the relevant list from the File menu.

2. Select the category. In Compact mode click on:  

3. Select the relevant subcategory. In Compact mode click on: 
4. Select the title of the bookmark you want.

Simple search

To search for a bookmark, type the text to search for in the search box at the bottom of the program
window. Pause and search results will be  shown. Items not matching the search term are grayed and
the first match is selected.

Press Enter/Return to open the first selected bookmark.

Press F3 (Find next) to skip forwards through the search results, and Shift+F3 (Find previous) to skip
backwards through the search results.

To turn the search results highlighting off, type Ctrl+F or click on the Search button  again.
Highlighting is automatically turned off when Bookmark Buddy is minimized.

To highlight search results again, click on the Search button  or type Ctrl+F .

By default a simple search looks for matches in titles, notes and keywords; it is case-insensitive,
matches partial words (e.g. ‘news’ will match ‘newspapers’ and ‘BBC News’), ignores spaces (e.g. ‘Buy
Domains’ will match ‘BuyDomains’) and exclude SmartFolders; and results are displayed by graying the
non-matches in the main application window.

To change the default settings for ‘simple’ searches:

1. Select Simple from the Preset drop-down list at the bottom of the Advanced search window (see
below).

2. Make any changes you want to the search settings.
3. Select Custom from the Preset drop-down list (so that you do not change the simple search settings

when you next do an advanced search).

Advanced search

To open the advanced search window, either:

Right-click on the Search button .
From the Edit menu select Search.
Type Ctrl+Shift+F.

The advanced search allows you to set a wide variety of options and filters for your search:

restrict searching to specific fields
set case-sensitive or whole word matching, ignore spaces



Finding & Opening Bookmarks 18

© Edward Leigh 1998-2015

include/exclude SmartFolders
filter results by rating, date or site status (as last checked by Bookmark Buddy)
choose whether search results are displayed by highlighting (graying non-matches) or as a list
search all lists until a match is found

Preset searches

You can store search settings for later re-use:

1. Set up your search (typically with the Custom preset selected).
2. Click the + button to the right of the Preset drop-down list.
3. Enter a name for the preset.

To re-use the search in future, simply select it from the Preset drop-down list. Note that the search word/
phrase is stored with your own presets, unlike for the default presets, Custom and Simple.

Tips

Leave the Search for field blank if you just want to filter results.
Turn on auto-opening to quickly find and open bookmarks.
Use keywords to label or tag bookmarks in the same way that you tag or label your digital photos.
Assign unique, short keywords to commonly-used bookmarks. To ensure uniqueness, include an
uncommon character (e.g. ~, #, [, ], {, }). So, for example you might create short abbreviations ending
with a ‘#’: goo# (Google), oe# (Outlook Express), bbcn# (BBC News).
Use advanced search to create export lists: select Mark found from the Edit menu, then Export from
the File menu, then check Include only marked bookmarks on the Export dialog window.

See also:

Open a Bookmark
Notes Window
Check bookmarks

8.2 Open a Bookmark

To open any type of bookmark

Click on  (or ) when the bookmark’s title is highlighted.
Double-click on the bookmark’s title (or single-click if you set the relevant Behavior option).
Type Ctrl+O when a bookmark’s title is highlighted.
Press Return/Enter when the bookmark’s title is highlighted.

When opening an Internet bookmark, these methods will use the default web browser and the default tab

(  – new or  – frontmost). Hold down the Shift key to temporarily switch the frontmost/new tab
default.

To open multiple bookmarks

Mark (Ctrl+click) the bookmarks you want to open.
From the Edit menu select Open marked or type Ctrl+M.

To open all the bookmarks in a subcategory, right-click  on the subcategory and select Open all.

If there are groups of bookmarks that you regularly want to open, create aliases of them in a
subcategory of their own, then you can open them by right-click ing on the subcategory and selecting
Open all.

Additional ways to open an Internet bookmark

Drag the bookmark’s title onto a browser window. Note that the Last Visited time may not be updated
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(see Known Problems).
Right-click  on the bookmark’s title and select Open in new tab or Open in frontmost tab or, if more
than one browser is configured, select a browser from the Open with menu item.

Right-click  on  (or ) when the bookmark’s title is highlighted and select Open in new tab or
Open in frontmost tab or, if more than one browser is configured, select a browser from the Open with
menu item.

You can set which is the default window for Internet bookmarks in Behavior Preferences or by right-

click ing on  (or ) and selecting Switch new/frontmost default. The current default behaviour is
marked by a bullet (as well as being indicated by the button icon).

You can set which is the default web browser by selecting Set default from the Browser menu (available

in Regular and Organize modes) or by right-click ing on  (or ) and selecting a browser from the
Set browser default menu item. You can also set a preference for an individual bookmark in the
extended notes.

To open the folder containing a local file bookmark

Right-click  on the bookmark’s title and select Open Folder.

Right-click  on  when the bookmark’s title is highlighted and select Open Folder.

To open Windows Explorer instead of a folder window, select Explore instead of Open Folder.

To minimize Bookmark Buddy after opening a bookmark

Hold down the Alt key when opening a bookmark and Bookmark Buddy will immediately minimize itself.
Or you can set Bookmark Buddy to automatically minimize after opening a bookmark (see Behavior
Preferences), in which case holding down the Alt key stops Bookmark Buddy minimizing. Pressing F12
minimizes Bookmark Buddy immediately.

How Bookmark Buddy opens a bookmark

If the bookmark path begins ‘http://’, ‘ftp://’, ‘file://’ etc, then Bookmark Buddy sends the bookmark
directly to the selected web browser. Otherwise Bookmark Buddy asks Windows to open the file, using
whichever program is associated with the file’s extension type (such as ‘txt’, ‘htm’, ‘gif’ etc).

If you open an html file and the bookmark doesn’t begin with ‘file://’ (e.g. the bookmark begins ‘C:\…’ or
‘\\fileserver\volume\…’) then the Windows setting for the default browser will be used, not the browser
selected in Bookmark Buddy.

If you include wildcards in the file name for a local document, Bookmark Buddy will open the document
with the last name that matches when they are sorted alphanumerically: 0…9, a…z, A…Z. See Add a
Bookmark for more detail.

See also:

Find a Bookmark
Add a Bookmark
Open a New Bookmark
Open a Blank Browser Window
Web Browsers
Behavior Preferences
Notes Window
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8.3 Fill Out a Log-in Form

To use the QuickLogin feature:

1. Open a bookmark as normal.
2. Check that the text cursor is flashing in the user name field. If it isn’t, click in it.
3. Type the hot key configured in the Hot Key Preferences.

- or -
Richt-click on the Tool Tray icon and select Fill out log-in form

Return to Bookmark Buddy and click on the log-in button  to the right of the log-in field on the
Notes window.
- or -
Return to Bookmark Buddy and type Ctrl+L.

If your log-in passwords are encrypted Bookmark Buddy will ask you for the decryption password the
first time you need to access a site log-in password. Bookmark Buddy will remember your decryption
password until you switch to a different bookmark list (unless you set the Behavior Preference
Remember encryption passwords til exit), or you exit Bookmark Buddy.

The QuickLogin feature works with most web page, popup dialog and application log-in forms. Bookmark
Buddy sends the log-in details to the last-active window; if you switch to another window before
switching to Bookmark Buddy, your log-in details may be entered into the wrong place.

Where a web log-in spans more than one field, use the ‘ ’̂ symbol to indicate a field break (i.e. tab to the
next entry box), e.g. 123^45^6789. If it takes two tabs to reach the password field, add a ‘ ’̂ to the end of
the log-in, e.g. username^. (This feature does not currently work for dialog/application windows.)

If the log-in field is pre-filled, double-click in the log-in box (selecting the log-in name) before using
QuickLogin. There is usually an option to turn off the pre-fill feature, e.g. ‘(do not) remember login’ or  ‘I
use a public/shared computer’.

If you find QuickLogin isn’t working properly, try increasing the QuickLogin delay in Behavior Preference.

Once you have entered your log-ins into Bookmark Buddy you may want to turn off the browser’s
‘autocomplete’ function. To do this in Internet Explorer:

1. In an Internet Explorer browser window select Internet Options from the Tools menu.
2. Click on the Content tab.
3. Click on the AutoComplete button.
4. Uncheck User names and passwords on forms.

See also:

Encrypt a Bookmark List
Notes Window
Behavior Preferences
Hot Keys

8.4 Schedule Visits

To schedule future visits to a web site:

1. Right-click on the bookmark and from the popup menu select Schedule next visit.
- or -

Select the bookmark and in the (extended) Notes window, click on the clock icon .
2. Select the hour and date when you would next like to revisit the site.
3. If you would like to schedule regular visits, select the interval.

Every fifteen minutes Bookmark Buddy checks for bookmarks that you have scheduled to visit now and
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adds an alias to them in the Due to Visit SmartFolder. A bookmark is never added more than once to
the SmartFolder. Once you have visited the site, the link is automatically removed from the SmartFolder.

To view all bookmarks with a visit schedule, open the List View window and, from the Show list, select
Scheduled.

See also:

SmartFolders
List View Window
Behavior Preferences
Notes Window

8.5 Open a New Bookmark

To open a new bookmark for which you have an address/URL:

1. From the Browser menu (which is only available in Regular/Organize mode) select Open a new
bookmark . If more than one browser is configured, select the browser you want to use.
- or -
Right-click on the Tool Tray icon and select Open new bookmark
- or -
Type Ctrl+Shift+N
- or -
Type the Open new bookmark  hot key

2. Type or paste the address of the bookmark you want to open.

See also:

Behavior Preferences
Hot Keys

8.6 Open a Blank Browser Window

To open a blank browser window: from the Browser menu (only available in Regular/Organize mode)
select Open blank window. If more than one browser is configured, select the browser you want to use.
The keyboard shortcut Ctrl+Shift+B will open a blank window in the default browser.

8.7 Copy a Bookmark to a Document

To copy a single bookmark (to the clipboard):

1. Select the bookmark.
2. From the Edit menu select Copy selected bookmark  as, and then select the format you want.

- or -
Right-click  on a bookmark and from the popup menu select Copy as, and then the format you want.
- or -
Type Ctrl+C to copy just the address.

To copy several bookmarks (to the clipboard):

1. Mark the bookmarks you want to copy.
2. From the Edit menu select Copy marked bookmarks as, and then select the format you want for the

copied bookmarks.

Switch to your document, e-mail message or web page and Paste the bookmark(s) where you want
them.
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See also:

Mark/Unmark Items

8.8 List View Window

The List View window gives you an alternative view on your bookmarks. You can choose from a number
of pre-defined views and perform various actions on selected items. Resize the window or scroll across
to see all of the available columns. Click on any column header to sort the list by that column. Click
between column headers and drag to the left or right to resize columns. Click on column headers and
drag to the left or right to re-order columns.

Views

From the Show drop-down list select what subset of the current bookmark list you would like to see:

Search results: Show the results of the last search. (If you always want search results listed here, set
this in the Advanced Search options.)

Marked: Show all the currently marked items.

Aliases: Show all aliases (instances) of the selected bookmark.

Duplicates (grouped): Show all bookmarks that share the same address as the selected bookmark.

Duplicates (all): Show all duplicate bookmarks in the current bookmark list.

Scheduled: Show all bookmarks for which a visit schedule is defined.

All: Show all bookmarks in the list.

Deleted: Show all bookmarks that have been deleted but not yet purged from the bookmark list.

Actions

To perform an action on some or all of the listed items:
1. Click on the checkbox by the items you want to apply the action to. To select multiple adjacent

items, click on the first checkbox then shift-click on the last checkbox. To select or unselect all the
listed items, click on the All checkbox at the bottom left of the window.

2. Select the action you want to perform. Depending on which view you select, two or more of the
actions listed below will be available to you.

3. Click on the Do button.

Open: Open the checked bookmarks in separate browser windows.

Mark : Mark the checked items.

Unmark : Unmark the checked items.

Delete: Delete the checked items.

Undelete: Undelete the checked items.

Convert to aliases: Merge the details of the checked duplicates into a single bookmark and make the
duplicates into aliases (instances of the same bookmark). This action is available only when the view is
Duplicates (grouped).

Delete permanently: Permanently erase the checked items from the bookmark list.

See also:

Mark/Unmark Items
Make an Alias of a Bookmark
De-duplicate Bookmarks
Delete Items
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8.9 Notes Window

To show or hide the notes window:

On the main program window, click on the notes icon  
Press F5
Type Alt+F5 (This activates the Notes window ready for entering text. Pressing Alt+F5 when the Note
window is visible reactivates the main program window.)
From the Application menu, select Show/Hide notes.

There are two tabs on the Notes window: the first contains your notes and login details; the second
contains your keywords/tags and visit details.

Hold the mouse cursor over any of the time-related fields to see the exact time and date.

To resize the window, click on any edge of the Notes window and drag.

With the text cursor in the notes box, type Ctrl+D to insert the current date.

Notes window buttons

 QuickLogin: Click on this to send the log-in name and password to the last active web page or
dialog box. Right-click to copy the log-in name and/or password.

 Set an encryption password: Click on this to encrypt your site log-in passwords.

 Passwords locked: Click on this to decrypt and/or reveal your site log-in passwords. See the
QuickLogin section for more detail.

 Passwords unlocked: Click on this to hide your site log-in passwords. See the QuickLogin section
for more detail.

 Scheduler: Click on this to schedule a visit to a bookmarked site.

Notes window fields

Notes: Your own notes

Log-in name: The log-in name needed to access the bookmarked site

Password: The log-in password needed to access the bookmarked site. The password is only shown
when you click inside the text box. If you store site passwords in Bookmark Buddy, you should
consider encrypting them.

Site updated: Date when the bookmarked page was last updated, according to the last background
check.

Rating: Your rating for the bookmarked site. This can be useful for choosing which of a number of similar
sites to try first. You can also filter search results by rating.

Last visit: Time you last visited the bookmark site (using Bookmark Buddy).

Previous visit: Time of previous-to-last visit.

Next visit due: Time of next scheduled visit.

Visits: Running total of the number of times you have visited the bookmarked site.

Keywords: Words (or easily-remembered abbreviations) that you would like to be able to search by to
find the bookmark. Also known as 'tags' or 'labels'.

Created: Date when you added the bookmark in Bookmark Buddy.

Modified: Date of last modification to any data associated with the bookmark.
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See also:

Add a Note
Find a Bookmark
Encrypt a Bookmark List
Behavior Preferences

9 Adding, Editing & Organizing Bookmarks

9.1 Add a Bookmark

There are many ways to add a bookmark to a Bookmark Buddy bookmark list:

Fetch from a web browser

Type the Fetch bookmark Hot Key.
Right-click on the Tool Tray icon and select Fetch from browser.

Click on the  button.
Type Ctrl+E to fetch the bookmark currently open in the frontmost tab of the default web browser.
From the Edit menu select Fetch from browser. If more than one browser is  configured, choose the
browser you want to fetch from.

Right-click  on the  button to bring up a pop-up menu of all the bookmarks currently open in the
configured web browsers. Select the bookmark you want to add.

Bookmark Buddy will check if the address/URL is already in the current bookmark list; if it is then you
will be prompted whether you want to add it as a new (duplicate) bookmark, create it as an  alias of the
existing bookmark(s), view the duplicates, or do nothing.

Drag and drop

Drag any of the following onto the main Bookmark Buddy program window:

The page address (or its icon) displayed in a browser window.
Links in web pages, documents, e-mails.
Shortcuts (e.g. on the desktop or in the Start Menu).
Program, document or folder icons.
Highlight text in a document or e-mail.

Create a new bookmark

Type Ctrl+N and type the new bookmark title and address.
Switch to Organize mode; click on the rightmost  button; and type the new bookmark title
and address.

If adding a program, file or folder shortcut, you can use the Browse  button to locate the file or
folder you want.

Choose which category and subcategory you want to add the bookmark to or use the  buttons
to create new headings. Then press Enter/Return in the title input box or click on the rightmost 
button when it is highlighted.

If the bookmark address already exists in the bookmark list, Bookmark Buddy will alert you and offer the
option to create an alias instead.

If a list box has previously been sorted into alphabetical order (see Sort or Re-order Items), then new
items are inserted in alphabetical order too. Otherwise new items are added at the bottom of the list box
(but you can then re-order them as you want).

Note that you can add e-mail addresses, path names to programs, folders and documents as well as
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Internet bookmarks, e.g.:

E-mail address: mailto:user@domain.com
E-mail address: mailto:Full Name<user@domain.com>
E-mail:* mailto:Full Name<user@domain.com>?cc=Another Person<user@domain.

com>&bcc=Secret Agent<user@domain.com>
News group: news:alt.comp.shareware
Program: C:\Program Files\Bookmark Buddy\BmkBuddy.exe
Program: D:\WebSvr\System\inetsw95.exe -w3svc -msftpsvc
Local folder: C:\My Documents\
Network  folder: \\Network Volume\Disk Name\My Documents\
Document: C:\My Documents\To Do List.txt

*This only works with some e-mail software.

Make sure that you include the full path name, including extension (‘.doc’, ‘.exe’, ‘.bat’ etc), of any
programs or documents you reference.

QuickSearch

To go straight to the search results on search engines, shop and auction sites etc, Bookmark Buddy
lets you pre-enter your search terms. To create a bookmark that will do this:

1. Go to the web site and do a simple one-word search.
2. Fetch the web address into Bookmark Buddy.
3. Examine the web address for where your search word is mentioned.
4. Replace the search word with the following: {{prompt}}
5. If you want to include your own prompt text, use: {{prompt:my prompt text}}
6. Add the bookmark to your bookmark list.

When you next open the bookmark, you will be prompted for your search word(s) before Bookmark
Buddy loads the web page. You will find some examples in the My Bookmarks bookmark list that
comes with Bookmark Buddy.

Wildcards

It is always a good habit to periodically save a document you are working on with a new file name so
that you have a revision history: e.g. Report 1, Report 2, … or Report 1a, Report 1b, Report 2a, ….
However you can’t easily create an alias to such a document since the alias is not updated when you
save the document with a new file name. Bookmark Buddy provides a solution: it lets you refer to the
latest document using wildcard characters in place of the version number/letter. An asterisk (‘*’) stands
for any number of characters; a question mark (‘?’) stands for a single character. When you ask
Bookmark Buddy to open the document, it will open the document with the last name that matches
when they are sorted alphanumerically: 0…9, a…z (case insensitive). For instance Report ??.doc or
Report *.doc would match Report 2b.doc if the only other files that could match were Report 1a.doc and
Report 2a.doc.

See also:

Add a Subcategory or Category
Move or Duplicate Items
Sort or Re-order Items
Hot Keys
Import a bookmark Collection
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9.2 Add a Subcategory or Category

To add a new subcategory or category:

1. Switch to Organize mode.
2. Click on the  button under the Subcategory or Category list box.
3. Type the name of the new subcategory or category.
4. Click on the  button.

See also:

Add a Bookmark
Move or Duplicate Items
Sort or Re-order Items

9.3 Edit an Item

To edit a bookmark, title, subcategory or category:

1. Select the relevant title, subcategory or category.
2. Right click on the item and select Rename this or switch to Organize mode.
3. Click on the edit box with the text you want to change. (The background will turn white.)
4. Edit the text.

To update the address/URL of a bookmark with the URL of an open web page:

1. Select the bookmark you want to update.
2. Hold down the Shift key while you fetch or drag a bookmark.

To update the path of a document, program of folder bookmark:

1. Select the bookmark you want to update.

2. Click on the Browse  button to locate the new file or folder.

See also:

Delete Items
Move or Duplicate Items
Sort or Re-order Items

9.4 Delete Items

To delete an item:

1. Select the bookmark, subcategory or category you want to delete.
2. In Organize mode, press the Delete key or click on the  button below the item you want to

delete.
- or -
Right-click  on the item and select Delete this from the popup menu.

To delete multiple items:

1. Mark each of the items you want to delete.
2. From the Edit menu select Delete marked.

If you try to delete a category or subcategory title that is not empty, you will be prompted to confirm that
you want to delete it.

If you try to delete a bookmark that has aliases, you will be asked whether you want to delete all the
aliases as well.

If you try to delete a SmartFolder, you will be warned that you cannot.
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Undelete

Deleted items are initially just hidden from view. They may be undeleted at any time until they are
purged from the bookmark list:

1. From the Edit menu select Undelete items.
2. Click on the checkbox by the items you want to undelete.
3. From the action list select Undelete.
4. Click on the Do button.

Purge deleted

To permanently erase all deleted items: from the File menu, select Purge deleted. To permanently delete
selected items:

1. Open the List View window.
2. From the Show option list select Deleted.
3. Click on the checkbox by the items you want to permanently delete.
4. From the action list select Delete permanently.
5. Click on the Do button.

See also:

Mark/Unmark Items
List View Window

9.5 Move or Duplicate Items

To move a single item:

1. Switch to Organize mode (F8).
2. Click on the item you want to move.
3. Drag the item onto the new category or subcategory*. To navigate inside another category or

subcategory, drag onto the category or subcategory and wait a moment for it to open.

To move one or more items to a new category or subcategory:

1. Mark the relevant items (Ctrl+click).
2. Right-click  on the category or subcategory you want to move the items into and from the popup

menu select Move marked in here.
- or -
Click on the category or subcategory under which you now want the marked item(s) to be listed.
Then from the Edit menu select Move Marked, then either Bookmarks or Subcategories.

To move items to different categories or subcategories:

1. Mark the items you want to move.
2. Open the List View window (F9) and select Show Marked.
3. Drag each item from the List View window onto the target category or subcategory*.

* Hold down the Ctrl key to create an alias instead of moving the item.

Mark  and Move is similar to Cut and Paste, but you cannot accidentally lose what you have cut before
pasting it. All marked items remain marked until Moved or Unmarked.

Move and copy items between lists

To move or copy items between lists:

1. Mark the items you want to move or duplicate.
2. Switch to the target bookmark list.
3. Right-click  on the category or subcategory you want to move/copy the items into and from the popup
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menu select Move marked in here or Duplicate marked in here.
- or -
Click on the category or subcategory under which you want the marked item(s) to be listed. Then
from the Edit menu select Move Marked, and either Bookmarks or Subcategories.

See also:

Mark/Unmark Items
Make an Alias of a Bookmark
Sort or Re-order Items
Edit a Bookmark List Manually

9.6 Make an Alias of a Bookmark

With Bookmark Buddy you can file a bookmark in more than one subcategory using ‘aliasing’. When
you create an alias, you create a link rather than a duplicate. This means that the details associated
with every instance are always identical, no matter which instance you open or modify.

To create an alias of a single bookmark:

1. Switch to Organize mode (F8).
2. Click on the item you want to create aliases of.
3. Drag the item onto the new subcategory whilst holding down the Ctrl key. To navigate inside another

category or subcategory, drag onto the category or subcategory and wait a moment for it to open.

To create an alias of one or more bookmarks:

1. Mark the bookmarks you want to create aliases of.
2. Right-click  on the subcategory or category in which you want the aliases to appear and select Alias

marked here.
- or -
Select the subcategory in which you want the aliases to appear. Then from the Edit menu select
Alias Marked, then Subcategory or Category.

If you alias a subcategory, the subcategory title is copied, but all the contained bookmarks are aliased.

Bookmark Buddy manages aliasing entirely transparently: you can re-title or move any instance of an
aliased bookmark. If you delete an instance of an aliased bookmark you will be prompted whether you
want to delete all instances or just the selected instance.

You can view all the instances of a bookmark by right-clicking on its title and selecting Show aliases.

See also:

Mark/Unmark Items
Move or Duplicate Items
List View Window

9.7 Mark/Unmark Items

Ways to mark an item

Hold down the Control (‘Ctrl’) key while you click on an item you want to mark.
Click on the item you want to mark and type Ctrl+X.
Click on the item you want to mark; then from the Edit menu, select Mark/unmark , then select either
Category, Subcategory or Bookmark .
Right-click  on the item you want to mark and select Mark this from the popup menu.

Marking an item automatically switches Bookmark Buddy into Organize mode.
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Ways to unmark an Item

Hold the Control  (‘Ctrl’) key down while you click on a marked item.
Right-click  on the item you want to mark and select Unmark this.
Click on the item you want to unmark; then from the Edit menu, select Mark/unmark , then either
Category, Subcategory or Bookmark .

Marked items are automatically unmarked after you move, duplicate or create aliases of them.

How to mark/unmark multiple items

To mark/unmark all the bookmarks in a subcategory, mark the subcategory.
To mark/unmark all the subcategories in a category, mark the category.
To mark/unmark consecutive items, click on the first item then Ctrl+Shift+click  on the last item.
Unmarked items are marked and marked items are unmarked.

Marking a category or subcategory automatically marks all of the items within it.

Ways to Unmark all Items

From the Edit menu, select Clear All Marks.
Right-click  anywhere inside a list box and select Clear All Marks from the popup menu.
Type Ctrl+Shift+C.

See also:

Move or Duplicate Items
Make an Alias of a Bookmark

9.8 Sort or Re-order Items

To re-order individual items in a list box:

1. Switch to Organize mode.
2. Click on an item and, whilst holding down the mouse button, drag the item up or down the list box as

required.

To alphabetically sort items a list box:

1. Switch to Organize mode.
2. Click on the  button under the relevant list box.

- or -
From the Edit menu, select Sort alphabetically, then either Bookmarks, Subcategories or
Categories.

To alphabetically sort an entire bookmark list:

1. From the Edit menu select Sort alphabetically then either All categories, subcategories &
bookmarks or, if you want to preserve the current ordering of categories and subcategories,
Bookmarks in all categories.

Note that if a list box contains a separator, the items above it are sorted independently of those below it;
the separator itself doesn’t move.

See also:

Move or Duplicate Items
Insert a Separator
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9.9 Insert a Separator

To insert a separator (a horizontal line) between titles:

1. Switch to Organize mode.
2. Click the right mouse button on the item you want to insert the separator before.
3. Select Insert Separator from the popup menu.
4. If you would like to include text within the separator, click in the box below the list box and type the

text you want to include.

See also:

Sort or Re-order Items

9.10 Add a Note, Log-in or Keywords

To add a note, keyword or log-in details:

1. Select the bookmark.
2. If necessary, show the Notes window by pressing Alt+F5.
3. To add a site password, you may need to unlock the field first.

To add a keyword, you may need to enable Extended Notes by typing Shift+F5 or clicking on the Extend

button  or .

Bookmarks that have a note associated are shown with a ¹ (superscript ‘1’); bookmarks that have a log-
in or password are shown with an ª (superscript ‘a’).

If you store site passwords in Bookmark Buddy, you should consider encrypting them.

See also:

Notes Window
Fill Out a Log-in Form
Encrypt a Bookmark List
Behavior Preferences

9.11 De-duplicate Bookmarks

To find duplicate bookmarks in a bookmark list:

1. From the Edit menu select Manage duplicates.
- or -

2. Open the List View window and select either Duplicates (grouped) or Duplicates (all) from the Show
drop-down list.

Duplicates (grouped) shows duplicates of the currently selected bookmark (if any).

Duplicates (all) shows all bookmarks that are duplicated, with all but one of each group of duplicates
already checked (ticked).

Duplicates are identified as having the same address/URL (ignoring upper/lower case differences).

See under List View for details of the actions you can perform on checked (ticked) bookmarks.

9.12 Check/Validate Bookmarks

Bookmark Buddy can check the status of bookmarks in the background to see if the web page has been
updated since you last visited it, or if it has moved or disappeared.

To check all your bookmarks, select Check status of … Entire bookmark  list from the Edit  menu. To
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check an individual bookmark, or a category or subcategory of bookmarks, right-click  on the title and
select Check bookmark(s).

You will see a progress window indicating which bookmark is currently being checked. Click on the 
Pause button to temporarily stop bookmark checking; click on Resume to continue checking from where
it stopped. Click Cancel to stop bookmark checking.

An alternative way to check a single bookmark is to right-click  on the Site status box and from the
popup menu select Check status now. This method does not open up the progress window.

Once checked, the site status is indicated in the box at the bottom-right corner of the main program
window. Where known, the date of the last update to the bookmarked page is shown in the Notes
window.

Once you have checked all your bookmarks you can filter them by site status using the final option on
the Advanced Search window or sort them by site status in the List View window.

Bookmarks that have been checked within the past hour are not re-checked. Therefore if checking is
interrupted for any reason, re-start checking within an hour and Bookmark Buddy will pick up from where
checking was interrupted.

What the site status terms mean

Not checked: You have not yet asked Bookmark Buddy to check the bookmark, or you have reset the
status. 

Check ing: Bookmark Buddy is in the process of checking the bookmark. This usually takes a second or
two.

Updated: The bookmarked page has changed since you last visited it.

OK: The bookmarked page was found and either it has not changed since you last visited it or the server
does not indicate when the page last changed.

Moved: The bookmarked page has moved to a new address.

Page not found: The bookmarked page no longer exists, but the domain name does.

Server not found: The domain name is unreachable, either because of a break in the Internet or because
the web site no longer exists.

Server error: Server responded with an error message, which means that there is a problem with the
server. However it does not always mean that the bookmarked page won’t load OK.

Not a valid URL: The bookmark address is not for a web site (beginning http:// or https://)

Unknown: The server did not respond (but the domain name exists) or its response contained nothing
meaningful about the status of the bookmarked page.

Caveats

Many web pages are ‘dynamic’ (built on the fly) and so it is not possible to determine when the content
was last updated. For such sites the bookmark status may always be ‘Updated’ or ‘OK’.

Many web servers do not return any meaningful information about the state of a URL; in which case the
status is reported as ‘unknown’.

Unfortunately some web servers return an error message or an incorrect response when asked about the
status of a bookmark. Therefore the site status should not be trusted 100%.

See also:

Notes Window
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9.13 Reset Last Visited Time

The Last Visited time is automatically updated whenever you open a bookmark from with Bookmark
Buddy.

To set it to indicate either that you have just opened the bookmark, or that you have never opened the
bookmark:

Right-click  on the Last Visited time in the Notes window and select either Set to Never or Set to Now.

If you select Set to Never, Bookmark Buddy resets the number of visits to zero. If you select Set to Now,
Bookmark Buddy increments the number of visits by one.

See also:

Notes Window

9.14 Undo Changes

You can undo what you type in an edit box by typing Ctrl+Z (the text cursor must be flashing in the edit
box).

To undo a deletion:

1. From the Edit menu select Undelete items.
2. Click on the checkbox by the item you want to undelete.
3. Select Undelete from the action list.
4. Click on the Do button.

To revert to the last-saved version of the bookmark list: from the File menu select Revert.

See also:

Save a Bookmark List
List View Window

10 Getting the Most from Bookmark Buddy

10.1 Tool Tray

If you check the Behavior Preference Use System Tool Tray, Bookmark Buddy displays an icon in the
System Tool Tray. The Tool Tray is the collection of icons shown usually at the right hand end of the
Windows Task Bar (the bar containing the Start button).

When Bookmark Buddy is ‘minimized’ or hidden it does not take up a slot on your task bar, which you
may find particularly convenient if you have a small screen.

Click (once) on the Bookmark Buddy icon to show or hide Bookmark Buddy.

Right-click on the icon to access various commands:

Fill out log-in form
Bookmark current page
Open new bookmark
Open a bookmark from your Favorites SmartFolder
Open a bookmark from your Due to Visit SmartFolder
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10.2 General Tips

You’ll find lots of useful tips in Bookmark Buddy’s tips window, which appears when you first start up the
program and which you can also open by selecting Tips from the Help menu.

There are also in-depth tips on the web site at: www.bookmarkbuddy.net/tips/

10.3 Keyboard Shortcuts

Most keyboard shortcuts are indicated on the menus: this list is a selection of the most useful.

F1 Open Help Notes (context sensitive)
F6 Switch to Compact mode
F7 Switch to Regular mode
F8 Switch to Organize mode
F12 Minimize Bookmark Buddy
Alt+F4 Exit Bookmark Buddy

F5 Show/hide Note window (without activating it)
Shift+F5 Extend/contract Note window
Alt+F5 Activate Note window
Ctrl+L Fill out last-active log-in form

Ctrl+O Open bookmark**
Ctrl+M Open marked bookmarks
Ctrl+E Fetch bookmark from frontmost web browser tab
Ctrl+N New bookmark
Ctrl+Shift+N Enter a bookmark to open in a new browser window
Ctrl+Shift+B Open a blank browser window
Ctrl+S Save changes

Alt+F Make Find box active and select search text
Ctrl+F Start/cancel search
F3 Highlight next search match
Shift+F3 Highlight previous search match
Ctrl+Shift+F Open Advanced Search window (also right-click  on Search button)

Ctrl+click Mark/unmark clicked item
Ctrl+X Mark/unmark selected item
Ctrl+Shift+click Mark/unmark all items between the currently selected and the clicked item
Ctrl+A Mark/unmark all items in active* list level
Ctrl+Shift+C Unmark all marked items
Ctrl+V Move marked items in active* list level
Ctrl+Down Sort items in active* list level
Ctrl+B Make selected item bold/unbold

Ctrl+C Copy selected bookmark’s address to clipboard
Ctrl+Shift+L Copy log-in name to clipboard
Ctrl+Shift+P Copy log-in password to clipboard
Ctrl+D Insert current date at text cursor (in Notes box)

Alt+C or 1 Make Category list box or menu active
Alt+S or 2 Make Subcategory list box or menu active
Alt+B or 3 Make Bookmark list box active

http://www.bookmarkbuddy.net/tips/
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F2 Edit item in active* list level
Alt+Shift+C or 1 Edit selected category
Alt+Shift+S or 2 Edit selected subcategory
Alt+Shift+B or 3 Edit selected bookmark
Ctrl+Alt+C or 1 New category
Ctrl+Alt+S or 2 New subcategory
Ctrl+Alt+B or 3 New bookmark

Tab Advance to next list or text box
Shift+Tab Return to previous list or text box
Cursor Right Advance to next list box
Cursor Left Advance to previous list box

Alt+A Move cursor to bookmark address field
Alt+N Move cursor to note field
Alt+L Move cursor to log-in field
Alt+P Move cursor to password field
Alt+R Move cursor to rating field
Alt+K Move cursor to keywords field

Return/Enter With caret in the search box: Start/cancel search;
With bookmark title list in focus: Open bookmark**;
With caret in an edit box and  highlighted: Add bookmark/title.
With caret in an edit box and  highlighted: Finish editing and move
focus to search box.

Ctrl+<digit> Switch to a different bookmark list (see File menu)
Ctrl+Tab Switch to bookmark list containing marked items or to previously open list

Ctrl+Alt+P Open preferences

*The active list level is the list box that responds to keyboard input. If the window style is standard
Windows, this is indicated by a dashed line around the selected item in the list. With the custom 
window style, this is indicated by a red (by default) border line around the list box.

**When you open a bookmark, you can change the default behavior by holding down either the Shift or
Alt key as follows: 

Hold down Shift key: Open bookmark with the frontmost/new tab default switched.

Hold down Alt key: Open bookmark then minimize Bookmark Buddy (or, if auto-minimize is set, do
not minimize Bookmark Buddy).

See also:

Hot Keys

11 Preferences & Configuration

11.1 Preferences

The application preferences are accessed by selecting Preferences from the Application menu. There
are five pages of preferences in a tabbed filing-card layout. When you press Apply, the changes made to
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the currently-showing preference card are applied immediately and the Preferences window remains
open. When you press OK, the changes are applied and the Preferences window closes.

See also:

Bookmark Lists
Web Browsers
Behavior Preferences
Hot Keys
Presentation Preferences

11.2 Web Browsers

When you install Bookmark Buddy it automatically configures optimal settings for any of the following
browsers installed on your computer:

AOL Explorer
Avant Browser
Crazy Browser
Firefox
Flock
GreenBrowser
Internet Explorer
Maxthon
Mozilla
MSN
MyIE
NeoPlanet
NetCaptor
Netscape Browser
Opera
Pale Moon
RealPlayer
SeaMonkey
SlimBrowser
Smart Bro
Winamp

To add support for a browser that you install after installing Bookmark Buddy:

1. From the Browser menu select Configure web browsers.
2. Click on the Look for installed browsers button.

Use the Remove button to remove a browser from the Browser menu.

Drag names up or down the list box to change the order in which they appear on the Browser menu.
Highlight the browser you want Bookmark Buddy to use as your default browser (this needn’t be the
same as the browser that Windows associates with web pages).

You can use any browser to open a bookmark from the Open with menu item available when you right-

click  on a bookmark title or on the Open Bookmark icon,  or . There is also an option in the
Notes window to set individual bookmarks to open with a particular web browser.

You can bookmark a page open in any browser window by right-clicking on the  button, selecting the
browser, then the title of the window you want to bookmark.

For further details, see: www.bookmarkbuddy.net/faq.php?q=browsers

http://downloads.channel.aol.com/browser/
http://www.avantbrowser.com/
http://www.crazybrowser.com/
http://www.mozilla.com/
http://www.flock.com/
http://www.morequick.com/indexen.htm
http://www.microsoft.com/ie/
http://www.maxthon.com/
http://www.mozilla.org/products/mozilla1.x/
http://www.msn.com/
http://www.morequick.com/myie.htm
http://www.neoplanet.com/
http://www.netcaptor.com/
http://browser.netscape.com/
http://www.opera.com/
http://www.palemoon.org/
http://www.real.com/
http://www.seamonkey-project.org/
http://www.flashpeak.com/sbrowser/
http://www.smartbro.com/
http://www.winamp.com/
http://www.bookmarkbuddy.net/faq.php?q=browsers
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Known limitations

Mozilla, Firefox and Netscape 8 are compatible with Bookmark Buddy except that you can only fetch

from the frontmost browser tab (i.e. right-clicking on the  button does not allow you to bookmark
other pages that you might have open in the same browser).

If you are running Windows 95 you may find that not all of these browsers are fully supported.

Unsupported browsers

Other browsers, including Google Chrome and Safari, are not fully supported because they do not
support one of the two standard protocols for inter-application communication (COM and DDE).
Bookmark Buddy can open bookmarks in these browsers, but it cannot fetch bookmarks  (but you
can still drag a bookmark from the browser’s address bar onto Bookmark Buddy).

To add an unsupported browser:

1. From the Browser menu select Configure web browsers.

2. Click on the Add button.

3. Navigate to the browser program file, in C:\Program Files\ or C:\Program Files (x86)\

See also:

Import a bookmark Collection
AOL users web page

11.3 Behavior Preferences

To set behaviour preferences, select Preferences from the Application menu.

Use System Tool Tray

If checked, Bookmark Buddy will create an icon in the Windows Tool Tray area.

Start program minimized

If checked, Bookmark Buddy will first start minimized to the Task Bar or System Tool Tray. This is most
useful if you set Bookmark Buddy to load when you start your computer (see Change Setup after
Installation).

Open Internet bookmarks in a new tab by default

If checked, Bookmark Buddy will open an Internet bookmark by default in a new web browser window
rather than in the frontmost browser tab. (See Open a URL for more details.)

Auto-minimize on opening bookmark*

If checked, Bookmark Buddy will automatically minimize after opening a bookmark. If you do not check
this option, you can achieve the same effect by holding down the Alt key when opening a bookmark; if
you do check this option, then holding down the Alt key prevents Bookmark Buddy minimizing.

Open bookmarks with one click on title*

If checked, Bookmark Buddy will open a bookmark with a single click on its title. When in Organize
mode or when you have the Notes window open, you will still need to double-click on a title to open the
bookmark.

Auto-open unique search matches*

If checked, Bookmark Buddy will automatically open a bookmark if it is the only match found for a
search. To search without auto-opening, use the function key F3.

Remember encryption passwords til exit

http://www.bookmarkbuddy.net/tips/aol.shtml
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Normally you have to enter the encryption password each time you open an encrypted bookmark list.
Set this option if you only want to enter the encryption password once during a session with Bookmark

Buddy. (You can still hide site passwords by clicking on the  icon in the Notes window).

Always direct typing to search box

Normally when the keyboard focus is on a list box, typing changes the selection to the next item that
begins with the letter typed. Set this option if you would prefer typing to be directed to the search box
instead.

Do not warn if bookmark list is read-only

If you share a bookmark list concurrently you may want to suppress the warnings that the list is read-
only. Note that the read-only status is also reported in the message-line.

Show message-line help

If checked, Bookmark Buddy will display brief help notes in the message line at the bottom of the 
Regular/Organize mode window. The notes describe the functions of such things as buttons and menu
items. The note shown corresponds to the button the mouse is hovering over or the currently highlighted
menu item.

Keep window at front*

You can choose, separately for the two window sizes, whether Bookmark Buddy stays in front of all the
other windows even when you are not using it. (You can always minimize all the windows.) 

Auto-dock Notes window**

If checked, Bookmark Buddy will always try to display the Notes window next to the main program
window. If there is not room to display it where you choose (at the side or below), then it will move to
where there is enough space.

You can also choose whether the Notes window extends horizontally or vertically.

Auto-hide Notes window**

If checked, Bookmark Buddy will automatically hide the Notes window when you select an item that
does not have a note or log-in associated with it.

QuickLogin delay

Adjust the slider to increase or decrease the delay before sending the login name and password to
another application. If you find that sometimes QuickLogin doesn’t work properly (nothing appears or
something appears but in the wrong place), try increasing the delay until it works for you.

*These options are also available on the main program window’s context menu (accessible by right-
click ing on any inactive or background area).

**These options are also available on the Notes window’s context menu (accessible by right-click ing on
any inactive or background area).

See also:

Presentation Preferences
Change Setup after Installation
Install

11.4 Hot Keys

Hot keys are keyboard shortcuts that work anywhere, not just when you are using Bookmark Buddy.
Make sure you use a key combination that doesn’t have a function in another application, since the hot
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key will override that function.

To set up or change hot keys, select Preferences from the Application menu. Then click on the Hot
Keys tab.

To set a hot key, click on the edit box and press the key combination you want to use. To disable a hot
key, click on the edit box and press the Delete key.

Activate Bookmark Buddy

Bring Bookmark Buddy to the front when using another application or, if Bookmark Buddy is already at
the front, then minimize it.

Fetch bookmark

Bring Bookmark Buddy to the front and fetch the bookmark from the frontmost browser tab.

Open new bookmark

Prompt for and open the address of a web site you want to visit.

Fill out log-in form

Send log-in details of last-selected bookmark to the currently active log-in form/window. Make sure the
caret (text insertion cursor) is flashing in the log-in name field. See QuickLogin section for more detail.

Note that these functions are also accessible from the Tool Tray icon.

See also:

Keyboard Shortcuts
Add a Bookmark
Open New Bookmark
Fill Out Log-in Form
Tool Tray

11.5 Presentation Preferences

To set presentation preferences, select Preferences from the Application menu. Then click on the
Presentation tab.

Window Style & Colors

Bookmark Buddy offers two window styles: standard 3D Windows controls in the standard colors or a
cleaner ‘flat’ style which can use a background color of your choice.

To change a color used by Bookmark Buddy, click on the swatch and pick a new color using the
Windows color picker. If the Custom window style is chosen, the Highlight color is used to indicate
which control has the keyboard focus. The Background and Text colors are ignored if the Standard
Windows style is chosen.

Font

There are two standard Windows fonts: MS Sans Serif 8pt and Tahoma 8pt. Which your computer uses
depends on the version of the operating system and which fonts are installed. You may need to resize
the windows after increasing the font size.

Highlight bookmarks visited within last … days

Type a figure in the box if you want Bookmark Buddy to highlight bookmarks that have been visited
within the last so many days. Leave the box empty if you do not want bookmarks to be highlighted. The
highlight color used is defined under Window Style & Colors (see above).

Maximum number of items in SmartFolders

Bookmark Buddy will maintain the contents of each SmartFolder so that it does not exceed the number
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you enter here.

See also:

Behavior Preferences
SmartFolders

11.6 Change Setup after Installing

To modify any of the setup options from within Bookmark Buddy select Modify Setup from the
Application menu.

Location of application files

If you specify a new location for Bookmark Buddy, Bookmark Buddy will exit when you press Setup Now
. You must then re-launch Bookmark Buddy in its new location. Any shortcuts will be modified to point
to Bookmark Buddy in its new location.

Shortcuts

If you deselect a shortcut option, the corresponding shortcut will be deleted; if you select a new shortcut
option, the corresponding shortcut will be created.

Default location for list files

If you change this, then any bookmark lists in the current default folder will be moved to the new
location.

See also:

Install

12 Support & Other Stuff

12.1 Problems

If you encounter serious problems with Bookmark Buddy, please check first that you are using the latest
version by visiting the program’s web site. If Bookmark Buddy doesn’t recognize that it is registered,
see Registration Problems.

If you are experiencing problems with the latest version, these are two possible causes which you may
wish to investigate:

The current bookmark list is corrupt

Bookmark Buddy automatically repairs a bookmark list if it can, saving a backup of the original list. If it
cannot repair the list, you should replace the bookmark list with one of the autobackup copies. You can
open a corrupted bookmark list in a text editor or a spreadsheet application such as Excel if you need to
recover bookmarks from it.

The Windows Registry settings are corrupt

Choose Uninstall from the program’s Application menu.*
Select only Remove entries from Windows Registry and press Uninstall Now.
When you next run Bookmark Buddy it will recreate the entries with default values.

If you can’t solve a problem then please contact me with the following information and I will endeavor to
come up with a solution:

1. The version of Bookmark Buddy you are using (see About Bookmark  Buddy)
2. The Operating System you are using (see the System Control Panel).
3. The steps you took before the problem occurred.
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4. Whether you can now reproduce the problem following the same steps.

*Users of Windows Vista and later must exit Bookmark Buddy, then choose Uninstall from the
Bookmark Buddy program group on the Start menu or via the Add or Remove Programs control panel.

Known problems

I am aware of the following problems:

Internet Explorer: Shift key interacts with opening bookmark in frontmost tab

If you use the Shift key to invert the action of opening a URL to open a bookmark in the frontmost
Internet Explorer tab, you may need to release the Shift key before Internet Explorer attempts to open
the bookmark or it will not open it. This is a bug in some versions of Internet Explorer.

Opera: bookmarks open in Opera when another browser is selected

If you have Opera loaded but you have Internet Explorer or Netscape/Mozilla selected in Bookmark
Buddy as the current browser, you may find that bookmarks will open in Opera’s frontmost tab, rather
than in the selected browser’s. This is a ‘feature’ or bug of Opera, which poses as Internet Explorer and
Navigator whilst loaded.

Drag and Drop: bookmarks dragged from Bookmark Buddy do not drop

Bookmark Buddy implements the core features of drag and drop, but these are not all implemented by
all applications (e.g. Opera and Microsoft Outlook Express). In these cases you should use Bookmark
Buddy’s alternative methods to open or copy a bookmark.

Drag and Drop: Last Visited time is not updated

Bookmark Buddy receives very limited feedback about what happens to a dragged bookmark: it doesn’t
even find out if the bookmark was dragged onto a web browser or a text editor. The way I have
implemented it, Bookmark Buddy updates the Last Visited time if you drag a bookmark onto Internet
Explorer, but not if you drag it onto most other applications (including Netscape/Mozilla). Therefore you
may want to use the Drag and Drop feature to open a bookmark only in Internet Explorer.

Hot key: does not always activate Bookmark Buddy

The hot key may not function when a DOS/command prompt window is active or when the System Tool
Tray has the input focus. This is a limitation in some versions of Windows.

12.2 Frequently Asked Questions

Can I add a bookmark from within my browser?

Yes: set a  Fetch bookmark  hot key in Bookmark Buddy. Whenever you want to add the bookmark of
the currently-showing web page, just type the hot key, choose which category and subcategory to add it
to, and click the rightmost  button.

Does Bookmark Buddy synchronize bookmarks between browsers?

No. Bookmark Buddy is designed as a stand-alone bookmark manager that works with most browsers,
including Firefox and Internet Explorer. Apart from the fact that syncing in two directions is almost
impossible to do reliably, Bookmark Buddy stores far more information than IE or Firefox, which
therefore has to be held separately from the browsers' own stores. Bookmark Buddy's own bookmark
store is a small text file, which you can easily back up or transfer to a memory stick to use with the  
Reader edition of Bookmark Buddy.

Does Bookmark Buddy work with AOL?

Bookmark Buddy works with the AOL Explorer (but not older editions of the AOL browser). Bookmark
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Buddy can also import your AOL Favorite Places (see Importing a Bookmark Collection), but cannot
export them back to AOL.

How do I recover my registration?
You can obtain a new copy of your Personal License Register immediately from OSoLiS: see 
Registrations Problems.

My e-mail address has changed since registering

Simply log in to your account with OSoLiS to update your contact details: www.osolis.com/login.cgi?
update.

Why the non-standard interface?

Windows Explorer-style tree lists and hierarchical menus permit you to create any number of levels, but
they are slow to navigate around, are cumbersome to edit, and they require lots of space on screen. By
contrast, Bookmark Buddy’s interface requires you to make no more than three mouse clicks to get to a
bookmark; editing, re-ordering or regrouping items is quick and easy; and the interface is compact.

Why only three levels?

In order to create a compact, simple but powerful interface. If you have, on average, 15 items at each
level, you can comfortably store over 3,500 bookmarks. If you break your bookmark collection into
separate lists (effectively creating a fourth level), you can readily store and retrieve tens of thousands of
bookmarks. You can use separators to achieve visually what another sub-level would. And you won’t find
yourself wasting time drilling down 5 levels to find a bookmark that you can’t quite remember how you
categorized. The next edition of Bookmark Buddy will support multiple filing levels.

See also:

Behavior Preferences
Support web pages

12.3 Support & Feedback

Support is always available by e-mail if you encounter a problem or can’t work out how to do something.
But please check these Help notes first to save both you and me time.

The Bookmark Buddy web site is kept up-to-date with news of the latest version available and a link to
download it. If you have a comment, gripe or suggestion, feel free to e-mail me. If you discover a bug, I
can usually get a fix posted to the web site within a few days. If you have requests or suggestions, I can
let you know if or when I intend to implement them.

Thank you for choosing Bookmark Buddy.

Edward Leigh

Web site

www.bookmarkbuddy.net
Support pages (FAQ, tips etc)
Contact form

E-mail

author@bookmarkbuddy.net

http://www.osolis.com/login.cgi?update
http://www.osolis.com/login.cgi?update
http://www.bookmarkbuddy.net/support.shtml
http://www.bookmarkbuddy.net/
http://www.bookmarkbuddy.net/support.shtml
http://www.bookmarkbuddy.net/contact.shtml
mailto:author@bookmarkbuddy.net
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12.4 History of Changes

3.9.3 Released 1 February 2015
Minor tweaks and bug fixes

3.9.2 Released 25 January 2015
Minor tweaks and bug fixes
Tested on Windows 10

3.9.1 Released 14 August 2014
Minor tweaks and bug fixes

3.9.0 Released 22 July 2014
Redesigned Notes window
Improved list corruption detection and repair
Improved QuickLogin
Re-use remembered decryption password when opening another list
Compatibility update for Firefox
Minor enhancements and bug fixes

3.8.0 Released 15 September 2013
Real-time search results
Improved multi-list searching
Enhanced QuickSearch function
Added 'bookmark modified' date to Advanced Search options
Added option to sort all bookmarks
Compatibility update for Pale Moon browser
Minor enhancements and bug fixes

3.7.5 Released 24 June 2012
Minor enhancements and bug fixes

3.7.4 Released 12 July 2011
Compatibility update for Opera 11
Minor enhancements and bug fixes

3.7.3 Released 10 May 2011
Compatibility update for Firefox 4
Minor tweaks and bug fixes

3.7.2 Released 28 March 2011
Compatibility updates for Firefox 4

3.7.1 Released 6 November 2010
Added 64-bit Program Files directory awareness
Added support for Pale Moon browser
Compatibility updates for various browsers
Fixed QuickLogin issue with Mozilla-based browsers

3.7.0 Released 7 September 2009
Upgraded 'Reader' edition to fully-functional 'Portable' edition
Usability enhancements, including multi-monitor awareness
Added support for Winamp browser
Compatibility updates for Internet Explorer and other browsers
Minor bug fixes

3.6.6 Released 5 May 2009
Bug fix for importing Firefox 3 bookmarks
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3.6.5 Released 6 January 2009
Added import support for Firefox 3 bookmarks
Compatibility updates for other import formats

3.6.4 Released 15 December 2008
Compatibility updates for various browsers
Added support for Flock and SeaMonkey browsers
Minor bug fixes

3.6.3 Released 14 June 2007
Minor bug fixes (inc. exporting/importing IE Favorites)

3.6.2 Released 28 April 2007
Added import support for Compass and Powermarks bookmarks
Minor bug fixes to import/export routines

3.6.1 Released 16 February 2007
Added support for Maxthon2 browser
Minor bug fix (installing as an update)

3.6.0 Released 13 February 2007
Windows Vista compatible
Added List View option to show all duplicates in current list
Added pre-selection of duplicates for deletion or aliasing
Added support for '̂ ' (move to next field) in site password field
Added support for importing bookmarks from Safari
Several tweaks and minor bug fixes

3.5.6 Released 6 December 2006
Various usability enhancements
Improved operation under 'limited user' accounts
Minor bug fixes

3.5.5 Released 1 November 2006
Added option to auto-hide notes window
Updated support for latest browser releases (inc. IE7 and AOL Explorer)
Minor bug fixes

3.5.4 Released 22 June 2006
Added indicator for bookmarks with a log-in
Upgraded help system to HTMLHelp
Minor tweaks and bug fixes

3.5.3 Released 21 April 2006
Updated Netscape/Mozilla/Firefox export template
Added Real Player browser support
Fixed list path issues for Reader Edition
Added keyboard shortcuts for main program window: Alt+N,L,R,K
Minor bug fixes

3.5.2 Released 13 December 2005
Now available as a 'reader' (read only) edition
Added keyboard shortcut (Ctrl+D) for adding date to notes
Various tweaks to user interface
Minor bug fixes

3.5.1 Released 30 September 2005
Now available in standard and Unicode editions
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Fully-automated uninstall for Windows 9x
Minor bug fixes

3.5.0 Released 25 August 2005
Added sortable columns to List View window
Added functionality to Tool Tray menu
Enhanced internal drag’n’drop functionality
Improved compatibility with most browsers
Updated import/export to match changes in Opera 8 & Netscape 8
Improved QuickLogin behaviour
Modified display of passwords for greater security
Added 2 templates: DHTML with floating window & Excel XML
Internal changes to enable Unicode-compatibility
Minor bug fixes

3.4.1 Released 16 June 2005
Added 'javascript' field format to template parser
Minor bug fixes

3.4.0 Released 10 June 2005
Added facility to store multiple search settings (presets)
Added Due To Visit alert dialog
Enhanced 'revert' function to restore from any auto-backup
Implemented 10 minute auto-save feature
Added option to search through all lists
Added auto-open option for unique search matches
Added title tips to List View window
Tweaks to user interface
Minor bug fixes

3.3.4 Released 4 April 2005
Added title tips to display titles that are wider than the list box
Added option to automatically direct typing to search box
Minor bug fixes

3.3.3 Released 18 March 2005
Added option to prepend http:// to imported bookmarks
Minor bug fixes

3.3.2 Released 1 February 2005
Various minor tweaks
Documentation updates

3.3.1 Released 10 January 2005
Made more organize functionality available in 'Compact' mode
Added 'Open marked' menu option
Enhanced List View functionality
Re-organized Edit and context menus
Different window arrangements remembered for Compact and Regular modes
Fixed problem with 'corrupted' bookmark lists
Minor bug fixes

3.3.0 Released 13 December 2004
Added List View for search results, marked, et al
Added facility to manage duplicates
Added undelete facility
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Added facility to identify groups of aliases
Enhanced autobackup to maintain three-stage backups
Implemented full drag and drop support
Improved multi-browser support
Improved mouse wheel support
Updated import/export to support Firefox 1.0
Advanced search settings are now remembered
Program can now be trialed under a 'Limited User' account
Installer exe built with GSfx Wizard – www.gdgsoft.com/gsfx/
Many usability improvements
Minor bug fixes

3.2.5 Released 27 August 2004
Added option to set the hour of scheduled visits
Various tweaks and bug fixes

3.2.4 Released 9 August 2004
Updated MSN import to handle MSN 9 favorites files
Various tweaks and bug fixes

3.2.3 Released 26 July 2004
Tweaks to QuickLogin, including adding ‘tab’ support
Added 'Open all bookmarks' to subcategory context menu
Added keyboard shortcuts
Updated templates

3.2.2 Released 21 June 2004
‘Simple’ searches now ignore space differences
Added advanced search option ‘Ignore spaces’
Made Notes window fully resizable
Added XML export template
Minor bug fixes

3.2.1 Released 11 June 2004
Minor bug fixes

3.2.0 Released 7 June 2004
Added template-based export facility
Added import/export support for MSN Favorites
Added import support for Compuserve 2000
Added export support for Windows shortcuts
Enhanced other aspects of import/export functionality
Added tips feature
Made Notes window resizable in one direction
Fixed problem with changing encryption options
Various tweaks and bug fixes

3.1.2 Released 20 May 2004
Fixed problem with importing AOL Favorite Places

3.1.1 Released 18 May 2004
Improved compatibility of Netscape/Mozilla import routine
Added Start Menu program group to install options
Improved uninstall
Various tweaks and bug fixes

3.1.0 Released 14 April 2004
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Added progress window for bookmark checking
Added options to check bookmarks in categories/subcategories
Added option to apply ‘advanced’ parameters to ‘simple’ searches
Optimized repeat searches and added ‘find previous’
Various tweaks and bug fixes

3.0.1 Released 15 March 2004
Added menu item, keyboard shortcut and hot key for filling out log-in forms
Added option to remember bookmark list encryption passwords
Various tweaks and bug fixes

3.0 Released 1 March 2004

2.x URL Organizer 2 - now  dist r ibuted separate ly

1.x URL OrganizerFree - now  dist r ibuted separate ly

12.5 Plans for Future Releases

Features to be included in future updates to Bookmark Buddy:

Synchronize copies of the same bookmark list
Support for multiple levels of categories
Guidance through installation
More advanced undo facility
Multi-colored headings
Maintain list of searched-for terms
Modernized interface
Have all bookmarks accessible directly from Tool Tray icon menu
Online bookmark storage facility

Although work on the next edition (major update) to Bookmark Buddy has started, no release date has
been announced yet.

If you have a suggestion, please feel free to e-mail me.

See also:

Upgrades

12.6 Background & Credits

Bookmark Buddy incorporates the SIVL verification software under license from OSoLiS (www.osolis.
com) ‘OSoLiS’, ‘SIVL’ and ‘Personal License Register’ are trademarks of OSoLiS LLC.

Bookmark Buddy is written in C++ using Microsoft Visual C++ .NET 2002.

These help notes (integrated, PDF and web site versions) were produced with Help & Manual - all from a
single source file.

My thanks go to all those users who have helped test Bookmark Buddy and URL Organizer and who
have made constructive suggestions on how to improve the program. In particular the contributions of
John Gibney and George Davis have been invaluable.

http://www.osolis.com/
http://www.osolis.com/
http://www.helpandmanual.com/
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